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1. Introduction 
 
A cognitive task analysis is to model the cognitive process that a learner takes on when he/she performs certain 
task (Jonassen, Tessmer, & Hannum, 1999). That is, the cognitive task analysis is an aid to identify and analyze 
cognitive processes that underline performance of tasks in consideration of observable behavior. A lot of studies 
were conducted to implement effective and efficient cognitive task analysis method (Carlisle, 1986). For 
example, knowledge audit method provides the results of survey for clarifying a task through probing concrete 
examples in real context. In addition, task diagram method provides broad overview of a task and highlights 
unknown portion of cognitive process by asking an expert to break down the task (Uden & Willis, 2001). 
 
However, a computerized aid for a cognitive task analysis has been greatly paid attention because a cognitive 
task analysis is intrinsically labor intensive, time consuming, and costly activity. As a result, some computerized 
cognitive task analysis tools were developed and used to support that processes. Williams and Voigt (2000) 
reported that a computerized aid called CAT (Cognitive Analysis Tool) was very helpful to conduct a cognitive 
task analysis in terms of accuracy and consistency of the work. The functions of the tool are goal setting, method 
selection, condition selection, undefining step, subgoal step setting, and primitive step setting. Following a linear 
process, a user can create detail description of each task and condition. In addition, he/she can add and link a 
goal that he/she specified and method, and condition. 
 
Welie, Veer, and Eliens (1998) developed a cognitive task analysis tool named Euterpe which focuses on 
hierarchical structure of tasks and relationship between the tasks and their properties. Basic concept underlying 
this tool is that a task is composed of object and a variety of properties and the task analysis is to connect them 
by specific rules. Another tool, HTA (Hierarchical Task Analysis) tool graphically illustrates split tasks and 
imposes a purpose, responsibility and condition of those tasks in hierarchal task branches. Microsaint was also 
developed to assist and facilitate a cognitive task analysis. Those tools listed above visually display a task and 
the flow of task analysis process by dragging and dropping a function. Especially, Microsaint adopts the 
simulation techniques in conjunction with the cognitive task analysis process. 
 
The purpose of this study is to review the theoretical background and functions of each tool and, as a result, 
suggest some findings for developing new cognitive task analysis tools. Especially, this study seeks to clarify 
following questions: 1) What theory is being adopted in the tools; 2) What methodology is being used in the 
tools; 3) What functions do the tools have; and 4) What implications the study findings have on the following 
new tools for the cognitive task analysis. 
 
 
2. Review of the tools 
 
A. Euterpe 
 
Product details: 
Product name: Euterpe 
Product Category Cognitive task analysis tool 
Producer name: Welie, M., Veer, G. C., & Eliëns, A. 
Product link: http://www.cs.vu.nl/~gerrit/gta/euterpe.html 
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Snapshot review: 
Ease of installation **** 
Ease of navigation *** 
Documentation * 
Pedagogical Foundation ***** 
Instructional Value **** 
Production Value ** 
Interactivity *** 

 
 
1. Overview 
 
Euterpe was developed on the basis of an object-oriented programming approach. It disseminates the task into 
several object components such as object, attributes, actions, role, and events. Each component can be defined by 
its own characteristics. The user manipulates these components and makes a relationship among them by simply 
drawing a line that connects them. Euterpe supports a linear-fashioned task analysis process in series. 
 
Basically, Euterpe uses the Group Task Analysis (GTA) approach, which refers to the task as the combination of 
the situation, the people, their roles, and the work. This concept is reflected in the functions of Euterpe. In the 
past, task analysis has focused mainly on analyzing a single user and his/her tasks. Groupware Task Analysis 
expands task analysis by looking at a task-world from the perspectives of work, agents, and situation.  
 
It regards the task-world as an organization where many people do tasks, work together and interact with both 
people and objects. From the perspective of work, GTA looks at tasks, goals, actions, and procedures within an 
organization. On the other hand, from the perspective of agents, GTA looks at the people and machines that 
perform the work, what their role is in the organization, and how responsibilities are allocated.  
 
 
2. Features 
 

 
 
In the menu bar, there are ‘File’, ‘Edit’, ‘Insert’, ‘View’, ‘Window’, and ‘Help’ buttons. The File menu is used to 
open, save, print, and export the file. The Edit menu is used to cut, copy, and delete the task template. The Insert 
menu is used to put in the task temple in a row or series. The View menu is used to insert the task template and 
define specific constraints. The Window menu is used to arrange the icon and windows. The Help menu is used 
to enable the users to find the topics by index. 
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A template can be used to specify the details and name of a task. Select the View Template from the View menu 
or double click on the node in icon bar. A new window will pop up showing many details of the task. The user 
can fill in all the appropriate details and close the window by choosing ‘Ok’ or ‘Cancel’.  
 
The user can insert either child nodes or sibling nodes, which stand for a unit of the task. The corresponding 
function can be selected through the ‘Insert’ menu in menu bar by using the ‘Ins’ key, or by selecting the 
function from the context menu (right mouse button). The user can delete a single node or delete a whole subtree 
hanging on a node. Select the ‘Delete’ from the Edit menu to delete a node or Delete subtree to delete the whole 
subtree. 
 
In the Icon Bar, there are ‘New’, ‘Open’, ‘Save’, ‘Cut’, ‘Copy’, ‘Paste’, ‘Do’, ‘Undo’, ‘Add’ the task template in 
a row or series, ‘View’ percentage window, ‘Print’, ‘About Euterpe’, and ‘Help’ icons. 
 
There are five taps below the icon bar. The ‘Task’ tap is to show the flowchart of analysis results. The ‘Object’ 
tap stands for physical entity, name and value pairs. The ‘Agent’ is a class of individuals with certain 
characteristics. The ‘Role’ tab is a meaningful collection of tasks performed by the agent. The ‘Task’ tab is the 
actions to be performed to reach a goal. The ‘Event tab’ tap is the change in the state of the task. 
 
Each tap has its own template that is used for defining the properties of the task. Therefore, there are ‘Task’ 
template, ‘Object’ template, ‘Agent’ template, ‘Role’ template, and ‘Event’ template. Each template usually 
consists of name, type category which is ‘Individual’, ‘Organization’, ‘Role’, ‘Media support’, ‘add and 
remove’, and specification of its characteristics. 
 
 
3. Implications 
 
The task analysis process can be represented graphically. All tasks are represented in boxes and lines. This 
representation enables the users to organize the hierarchy and procedures of the task and task element. However, 
the types of representation are so limited that other representation systems, such as a box, a triangle, a circle, and 
a rhombus should be considered to present the types of task more effectively. 
 
The task itself can be divided into the task elements, properties, and commentary. The task element is a unit of 
task. The task element has several properties, which include the characteristics and conditions. The commentary 
is needed to provide the descriptions of the relationship between the task elements and the properties.  
 
The task can be represented in multiple ways. The existing tools such as Euterpe, basically assume that all tasks 
can be represented in various ways if represented by multimedia objects, such as a graphic, sound, and movie 
file. The user should have to represent the task with multimedia types by manipulating some functions which are 
provided by the tools. 
 
The complex level of the task should be considered. Euterpe emphasizes complex tasks and their linkages. The 
user can’t determine the level of complexity when he/she analyzes the job and the task. By adding complexity 
level icon and/or designating the complex level when starting the analysis, the user can represent the task more 
specifically. 
 
 
B. HTA (Hierarchical Task Analysis) 
 
Product details: 
Product name: HTA (Hierarchical Task Analysis) 
Product Category Cognitive task analysis tool 
Producer name: Humanreliability associates 
Product link: http://www.humanreliability.com/software.html 

 
Snapshot review: 
Ease of installation **** 
Ease of navigation **** 
Documentation ** 
Pedagogical Foundation ** 
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Instructional Value *** 
Production Value ** 
Interactivity ** 

 
 
1. Overview 
 
Hierarchical Task Analysis (HTA) tool is a systematic support tool for describing how tasks are organized. It 
identifies the overall objective of a job, the overall goal of the task, what sub-tasks are needed to achieve that 
goal, and when each sub-task should be carried out.  
 
The users always start by stating the overall objective. Then this objective is broken down into sub-tasks. These 
tasks will have a certain order or set of conditions under which each sub task should be performed. This is called 
a ‘Plan’. 
 
The HTA adopts the hierarchical task analysis approach in which the users break down and display the task 
hierarchically from top to bottom to show a hierarchical relationship among the tasks. Thus the users easily 
understand the path of the task sequences and their relationships. 
 
 
2. Features 
 

 
 
In menu bar, there are ‘File’, ‘Edit’, ‘Insert’, ‘View’, and ‘Options’. The File menu is to open, save, and print the 
file and define the properties of the task and its procedures. The Edit menu is to cut, copy, and paste the task 
templates. The View menu is to select the page, which is previously ‘Split and Zoom’ function. The Options 
menu is to adjust the view of graphic interface.  
 
In the icon bar, from the left, there are ‘Split Window’, ‘Center Focusing’, ‘Go To Top Menu’, ‘Move Up Tree’, 
‘Insert Page Down’, ‘Insert Page Left’, ‘Insert Page Right’, ‘Child Box’, ‘Left Box’, ‘Right Box’, ‘Parent Box’, 
‘Preconditioned Box’, ‘Plan’, ‘Erase’, ‘Expand’, ‘Contract’, ‘Zoom In’, ‘Zoom Out’, and ‘Add a Unit’. 
 
Basically, HTA has four templates: ‘Properties’ template which specifies source file, project name, task goal, 
analysis status, date, and backup interval. ‘Procedure’ details template has the task goal, purpose, 
responsibilities, and pre-conditions. ‘Page Select and Reorder’ template is used to rearrange the order of the box 
and its labels and ‘Split-screen’ template is the description of each task number and piece of information. 
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3. Implications 
 
The HTA enables the user to sequence the logic of the task by adding child and parent nodes hierarchically. This 
type of cognitive task analysis tool may be more suitable to hierarchical tasks which emphasize intellectual 
skills. This gives the researcher an idea that the user should be allowed to manipulate the sequence of the task 
based on the type of task. That is, the user may need to organize the sequence of the task depending on the task 
type such as intellectual skill, motor skills, and verbal information. 
  
If the task is performed by several users collaboratively and/or has sub-tasks performed by different users, HTA 
indicates who performs the task. This can make it evident who is responsible for the task or sub-task (i.e., 
accountability). In addition, this can be basic data for tracking a specific user’s performance.  
 
There should be specific functions for merging some tasks. The more complex the task is, the better the task is 
congregated. If the complexity of the task is increasing, the user may not identify the entire task obviously. So, if 
the user can combine some tasks according to the job/task specification in one group, the user will recognize 
whole structures and sequences of the task at a glance. 
 
The characteristics of job and task should be more specified. When the user defines the job and task, he/she 
needs to describe detail information of the job and the task such as the job/task goal, purpose, constraints, and 
pre-defined conditions to be performed. In addition, these elements should not be separated differently. The 
commentary, which is the descriptions of the relationship between the task elements, can be an example. 
 
With specific characteristics of job and task, there should be specific criteria for achieving these job and tasks. 
This criteria or guidelines can help the evaluator as well as the learner to gain information about achievement 
level and minimum requirements. HTA seems to overlook the importance of evaluation of the tasks. These 
criteria or guidelines can be suggested as pull down menus based on performance, complexity, and acceptance 
level of the job and the task. 
 
 
C. CAT (Cognitive Analysis Tool) 
 
Product details: 
Product name: CAT (Cognitive Analysis Tool) 
Product Category Cognitive task analysis tool 
Producer name: Kent E. Williams 
Product link: http://www.iems.ucf.edu/ver40/faculty/william.htm 

 
Snapshot review: 
Ease of installation ***** 
Ease of navigation ** 
Documentation *** 
Pedagogical Foundation ***** 
Instructional Value *** 
Production Value *** 
Interactivity ** 

 
 
1. Overview 
 
The CAT is designed to support a cognitive task analysis. This tool begins by suggesting two options, which are 
‘Tutorial format’ and ‘Guidance format’. One of the options, the tutorial format is led by an electronic manual 
and its topics and the guidance format is led by step-by-step procedures for analyzing a task. 
 
The users should set the goal at the starting point and then specify the procedures in conjunction with stating the 
conditions. After finishing those processes, the user can add some description of them. 
 
This CAT was developed based on the GOMS (Goals, Operators, Methods, and Selection rules) model. A 
GOMS model is composed of Methods that are used to achieve specific Goals. The Methods are then composed 
of Operators at the lowest level. The Operators are specific steps that a user performs and are assigned a specific 

134 



execution time. If a Goal can be achieved by more than one Method, then selection rules are used to determine 
the proper method. 
 
 
2. Features 
 

 
 
The system menu area consists of the ‘File’, ‘Edit’, ‘Navigate’, and ‘Help’ drop down menus located below the 
title bar area. The File menu contains the ‘File Manipulation’ options, ‘Print Capability’ options, and 
‘Application Termination’ options. The Edit menu contains the model edit options used. The Navigate drop 
down menu is used in conjunction with the graphical user interface to navigate through the model, to provide a 
method of returning to ‘Guidance Mode’, and to execute an existing model. 
 
The Help menu is to assist the users. For example, it presents the menu items such as ‘Tutorial’ which presents a 
complete tutorial for using the CAT tool, ‘Help’ which presents detailed help for using the CAT. Interestingly, 
this menu has the option of ‘How to Use Help’. This menu option presents the users a lot of information on how 
to use the help system. 
 
From the top to the down, first icon represents the ‘Goal’, which allows the user to open a new model. Second 
icon, ‘Method’ is to add a new method to the current goal structure. Third icon ‘Selection condition’ is to add a 
new selection rule condition node to the model. Fourth icon, ‘Undefined step’ is provided only as a visual cue to 
indicate that there is undefined step in model.  
 
Fifth icon, ‘Sub goal step’ is to add a new sub-goal node to the current goal structure. Sixth icon, ‘Primitive 
Node’ is to add a user defined or predefined primitive node to the current goal structure. Seventh icon, ‘Group 
Step’ is to place over a method step will group it with the next method step. Last icon, ‘Ungroup Step’ is to 
enable the user to ungroup a step from those following by clicking and dragging this icon to the step to be 
ungrouped. 
 
When a user starts CAT, he/she can choose ‘Tutorial’ button which provides the user to access to the CAT 
tutorial when detailed step by step information about developing models using CAT is required or  ‘Guidance’ 
button, which provides the novice or intermediate user with a method to develop a ‘CAT’ model in a completely 
constrained ‘Guidance’ mode. 
 
The first input is to define the top level goal to be accomplished by the model. Once a top level or any other goal 
is defined, it is necessary to define the steps (sub-goals) for all the methods associated with it. ‘Steps’ are a 
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sequence of operators associated with the goal which or may not be further decomposed into additional methods 
and steps. 
 
CAT provides the users several templates such as ‘Enter sub goal information’ template, which is to define a 
sub-goal or primitive operator in the tool, ‘Decision step information’, which is to define a condition and an 
action to take if the condition is true.  
 
When the entering of the steps for a method has been completed, it may be necessary to specify a change in the 
order in which the steps were entered or to specify that step order is unimportant. 
 
 
3. Implications 
 
A new tool for the cognitive task analysis has to have a printing function which reports the user’s performance in 
terms of the characteristics of the job and the task. CAT has a function to report the results of cognitive task 
analysis. However, it does not seem to consider individual results of the performance in doing the task analysis. 
 
With drag and drop method, the user should be able to input the condition, goal, purpose, and method with text. 
Especially, it can be effective for the user to follow a pre-determined step-by-step analysis process at the 
beginning of the analysis.  
 
There is a specific function called ‘Grouping’ for merging some tasks. Unlike the HTA analysis tool, CAT 
enables the user can combine some tasks, conditions, and methods according to the job/task specification in one 
group. The user can recognize whole structures and sequences of the task at a glance. 
 
The condition clause (If-then) function can make the sequences of the task more flexible. For instance, if one 
task can be done in a different way, the if-then function allows the user to consider setting a different task 
sequence based on the user’s choice. 
 
 
D. Microsaint 
 
Product details: 
Product name: Microsaint 
Product Category Cognitive task analysis tool 
Producer name: MA&D 
Product link: http://www.maad.com 

 
Snapshot review: 
Ease of installation ***** 
Ease of navigation **** 
Documentation *** 
Pedagogical Foundation *** 
Instructional Value **** 
Production Value **** 
Interactivity ***** 

 
 
1. Overview 
 
Microsaint is a simulation-based task-analysis tool. Like other tools, this tool is used in different types of 
cognitive task analysis. However, this tool generates more powerful functions of the simulation to make the task 
more dynamic. 
 
Microsaint has strengths in specifying the descriptions of the task, designing the task flow, exchange the 
commands, and using the resource wizard. Unlike other tools, this tool does not provide any guidelines or rules 
when the users start the tool. The users can go to the main page directly and analyze the task. 
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This tool can support hierarchical and procedural analysis of the task. A hierarchical task analysis is developed 
bottom up, from general to specific. A hierarchical task analysis is based on learning taxonomies, starting from 
the most complex.  
 
The nature of the terminal task determines at which level in the taxonomy one should start breaking down the 
task from more complex to less complex, going through each of the learning levels.  
 
A procedural task analysis is developed linearly and sequentially, that is, step-by-step procedure. It has a 
directional flow. It has a start and an end. A procedural task analysis is not concerned with the levels of the 
learning taxonomies, it is procedural in nature.  
 
If the task is a relational rule, then the steps of the task analysis would include how to apply this rule. If the task 
is concept learning, then the task analysis would include how to determine whether a particular instance is an 
example of this concept. 
 
 
2. Features 
 

 
 
In the Menu bar, the ‘File’ menu includes the ‘New’, ‘Open’, ‘Save’, and ‘Print’ menus. The ‘Edit’ menu 
includes ‘Cut’, ‘Copy’, ‘Paste’, ‘Delete’, ‘Select all’, and ‘Check Syntax’. The search menu contains ‘Find and 
Replace’. The ‘Display’ menu contains the network diagram, variable catalog, function library, event queue, 
snapshot, action view, resource wizards, and external model calls. 
 
 The ‘Execute’ menu includes the ‘Go’, ‘Single’ step, and ‘Normal speed’ etc. The ‘Action View’ menu is to 
adjust the speed of media player. The ‘Analyze’ menu includes the result of statistics, various graphs, and the 
scales. The ‘Option’ includes the references. The ‘Window’ menu is to change the arrangement and the size of 
the windows. The ‘Help’ menu includes the help and using the help. 
 
From the left side, the first icon bar shows ‘New’, ‘Open’, ‘Save’, ‘Print’, ‘Print Preview’, ‘Select All’, ‘Cut’, 
‘Copy’, ‘Paste’, ‘Find’, ‘Replace’, and ‘Help’. In second icon bar, from the left side, this icon bar shows 
‘Network Diagram’, ‘Variable Catalog’, ‘Function Library’, ‘Event Queue’, ‘Snap Shot’, ‘Execution Monitor’, 
‘Action View’, ‘Optimize, Resource Wizard’, ‘Setting’, ‘Check Syntax’, ‘Go’, ‘Pause’, ‘Single Step’, ‘Top 
Speed’, ‘Add new item to list’, and ‘Halt’.  
 

137 



In third icon bar, this icon bar shows ‘Select’, ‘Network’, ‘Task, Queue’, ‘Path’, ‘Delete Path’, ‘Start’, ‘Text’, 
‘Near’, ‘Far’, ‘Undo’, ‘Down’, ‘Go To’, ‘Up’, ‘Create’, ‘Move’, ‘Delete Icon’, ‘Vertical Axis’, ‘Horizontal 
Axis’, and ‘Remove Graph’. 
 
Microsaint has several templates such as ‘Network Description’ template, which includes the network box 
selection, network number, and notes, ‘Task Description’ template, which includes the task box selection, task 
number, time, condition, beginning and ending effects, and ‘Job Description’ template, which includes the job 
queue number, queue number, entering effect, priority, and departing effect. 
 
The ‘Resource Wizard’ template is used to create or select a resource variable and to allocate resources to the 
tasks in a model. To display the Resource Wizard, from the Display menu, the user can choose Resource Wizard 
or click the Resource Wizard button on the toolbar. The user can also click the Resource wizard button in the 
‘Variable Catalog’ dialog box to open the Resource Wizard and follow the instructions in the Resource Wizard. 
The user can quit the Wizard at any point by clicking ‘Cancel’. 
 
 
3. Implications 
 
Tasks can be represented as multimedia elements. The Microsaint supports the user in representing the tasks in 
various ways such as a graphic, sound, and movie file. In addition, the user can manipulate specific properties of 
the multimedia elements. For instance, the user can adjust the starting point, duration, ending point, effects, and 
the play of the element by clicking the icon. 
 
The task library can be considered as a database. The user can select a specific task or task example in the 
library. The user attaches this task and task property in current designed task analysis template. The task library 
can be organized by type of job and task, knowledge and skills, performer, and complexity of job and task.  
 
The result of performance can be sorted and stored within the user’s personal database. If so, the new system for 
the cognitive task analysis has the criteria for each task if it is achieved. In addition, a personal database should 
be developed to sort and distribute each performed task by performance criteria and types of job and tasks. 
 
The resource wizard can be usefully used to create or select a task and task-process elements and to allocate 
these elements according to the tasks. Also, the wizard can be useful to start initial task analysis (i.e. Draft 
version of task analysis). If the resource wizard were successfully designed and implemented, only thing the user 
to do is to follow each guidelines suggested by wizard.  This can make the task analysis process effective as well 
as efficient. 
 
 
3. Conclusions 
 
The reviewer summarized the snapshot of the tools. This can be helpful to compare some features of the tools. 
 Euterpe HTA CAT Microsaint 
Ease of installation **** **** ***** ***** 
Ease of navigation *** **** ** **** 
Documentation * ** *** *** 
Pedagogical Foundation ***** ** ***** *** 
Instructional Value **** *** *** **** 
Production Value ** ** *** **** 
Interactivity *** ** ** ***** 

 
This study implicates 1) Existing tools should be redesigned to supplement their own weakness of functions and 
support the users to do the cognitive task analysis more flexible; 2) These tools should allow the users to choose 
one of the cognitive task analysis methods; 3) Some tools are based on DOS, not Windows. Various options for 
installing the tools should be considered; 4) New types of a cognitive task analysis tool can be considered to 
support cognitive task analysis in light of performance effectiveness, learnability, error tolerance, interactivity, 
user guidance, and screen layout; 5) Cognitive task analysis tool may be needed to connect with a job task 
analysis tool, competency analysis tool, or human performance tracking system. 
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